EIGRPルート手動集約とLeak-Mapの設定と確認方法

EIGRPのルート手動集約とLeak-Mapについてまとめています。
「Leak-Map?! なんじゃそりゃ??」と思いますよね〜(実務では使ったことないぞ。。。)
この技術は、Leak(漏らす)の意味の通り集約前のルートの一部を集約ルートに加えて広報する機能です。
集約させたけど、漏れちゃった。。って感じ?
集約ルートよりも細かいサブネットのルート情報を流して、トラフィックエンジニアリングさせる技術ですね。

EIGRPルート手動集約とLeak-Map検証構成

EIGRPルート手動集約とleak-mapの検証構成を以下に示します。

EIGRPルート手動集約とLeak-Map検証構成

現段階では、R1からR2へLo1-Lo4のネットワーク(10.1.1.0/24,10.1.2.0/24,10.1.3.0/24,10.1.4.0/24)を集約して1つの集約ルート(10.1.0.0/16)を広報しています。
1つの集約ルートを受け取ったR2のルーティングテーブルは下記のようになります。

R2のルーティングテーブル(Leak-Map使用前)

EIGRPルート手動集約とLeak-Mapの設定

R1においてLo1のネットワーク(10.1.1.0/24)をリークしてみようと思います。
設定コマンドはこちら。

EIGRPルート手動集約コマンド(Leak-Mapオプション)
(config-if)# ip summary-address eigrp as-number ip-address mask [admin-distance] [leak-map name]
集約コマンドのオプションでLeak-Map(route-map)を指定します。
ここでは10.1.1.0/24をリークしてみようと思いますので、下記コマンドになります。
R1:EIGRPルート手動集約&Leak-Map設定(ACL:10.1.1.0/24)
(config)# ip access-list standard LOOPBACK1
(config-std-nacl)# permit 10.1.1.0 0.0.0.255
(config-std-nacl)# exit
(config)# route-map LOOPBACK1-NW permit 10
(config-route-map)# match ip address LOOPBACK1
(config-route-map)# exit
(config)# interface GigabitEthernet0/0
(config-if)# ip summary-address eigrp 100 10.1.0.0 255.255.0.0 leak-map LOOPBACK1-NW
集約ルート(10.1.0.0/16)に加えて、リークルート(10.1.1.0/24)がR1から広報されます。

EIGRPルート手動集約とLeak-Map設定

ちなみにリークルートの指定にプリフィクスリストを使用することもできます。

R1:EIGRPルート手動集約&Leak-Map設定(Prefix-list:10.1.1.0/24)
(config)# ip prefix-list LOOPBACK1 permit 10.1.1.0/24
(config)# route-map LOOPBACK1-NW permit 10
(config-route-map)# match ip address prefix-list LOOPBACK1
(config-route-map)# exit
(config)# interface GigabitEthernet0/0
(config-if)# ip summary-address eigrp 100 10.1.0.0 255.255.0.0 leak-map LOOPBACK1-NW
ただし、ルートマップ内でインタフェースを指定した場合(match interfaceを使用した場合)は、うまくリークしてくれませんでした。。。
R1:EIGRPルート手動集約&Leak-Map設定(route-map(match interface):10.1.1.0/24)
(config)# route-map LOOPBACK1-INT permit 10
(config-route-map)# match interface Loopback1
(config-route-map)# exit
(config)# interface GigabitEthernet0/0
(config-if)# ip summary-address eigrp 100 10.1.0.0 255.255.0.0 leak-map LOOPBACK1-INT
また、Leak-mapオプションで指定したルートマップが存在しない場合は、単純にルート集約が行われます。

EIGRPルート手動集約とLeak-Mapの確認方法

R2のルーティングテーブルを確認して、ルートがリークできているか確認してみます。
使用するコマンドはshow ip routeコマンドです。

R2のルーティングテーブル(R1にてルート手動集約とLeak-Mapを設定後)

R1で集約したルート(10.1.0.0/16)に加え、リークしたルート(10.1.1.0/24)が広報されたことが確認できます。

参考文献

CCO
Configuring the EIGRP Route Summarization Autonomous System Configuration

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です